Bug 159902

Summary: NullPointerException at org.netbeans.modules.kenai.ui.KenaiFeatureCellRenderer.getListCellRendererComponent
Product: connecteddeveloper Reporter: Jan Becicka <jbecicka>
Component: Team FrameworkAssignee: Milan Kubec <mkubec>
Status: VERIFIED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P1    
Version: 6.x   
Target Milestone: 6.x   
Hardware: All   
OS: All   
URL: http://statistics.netbeans.org/exceptions/detail.do?id=147340
Whiteboard: EXCEPTIONS_REPORT
Issue Type: DEFECT Exception Report: 147340
Attachments: stacktrace

Description Jan Becicka 2009-03-09 12:49:38 UTC
Build: NetBeans IDE Dev (Build 090309)
VM: Java HotSpot(TM) 64-Bit Server VM, 11.0-b16, Java(TM) SE Runtime Environment, 1.6.0_11-b03
OS: Linux, 2.6.25.20-0.1-default, amd64

User Comments:
jbecicka: jscreenpicker project on testkenai.com trying to checkout sources



Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.kenai.ui.KenaiFeatureCellRenderer.getListCellRendererComponent(KenaiFeatureCellRenderer.java:140)
        at javax.swing.plaf.synth.SynthComboBoxUI.paintCurrentValue(SynthComboBoxUI.java:313)
        at javax.swing.plaf.synth.SynthComboBoxUI.paint(SynthComboBoxUI.java:295)
        at javax.swing.plaf.synth.SynthComboBoxUI.update(SynthComboBoxUI.java:279)
        at javax.swing.JComponent.paintComponent(JComponent.java:763)
        at javax.swing.JComponent.paint(JComponent.java:1027)
Comment 1 Jan Becicka 2009-03-09 12:49:43 UTC
Created attachment 77905 [details]
stacktrace
Comment 2 Jan Becicka 2009-03-09 12:51:44 UTC
demo blocker
Comment 3 Milan Kubec 2009-03-09 13:31:21 UTC
*** Issue 159905 has been marked as a duplicate of this issue. ***
Comment 4 Milan Kubec 2009-03-09 13:36:49 UTC
*** Issue 159908 has been marked as a duplicate of this issue. ***
Comment 5 Milan Kubec 2009-03-09 13:38:13 UTC
Are you logged in?
Comment 6 Jan Becicka 2009-03-09 14:12:54 UTC
Yes.
See also http://kenai.com/jira/browse/KENAI-263
web_url can be null. Do you use web_url?
Comment 7 Milan Kubec 2009-03-09 21:10:34 UTC
Fixed by jbecicka.
Comment 8 Jaromir Uhrik 2009-03-26 14:41:33 UTC
Verified in the following build/config:
Product Version: NetBeans IDE Dev (Build cdev-434-on-090326)
Java: 1.5.0_16; Java HotSpot(TM) Client VM 1.5.0_16-133
System: Mac OS X version 10.5.6 running on i386; MacRoman; en_US (nb)
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo