Bug 157898

Summary: NullPointerException at org.netbeans.modules.mercurial.ui.wizards.ClonePathsPanel.isValid
Product: versioncontrol Reporter: sflemming <sflemming>
Component: MercurialAssignee: issues <issues.netbeans.org>
Status: VERIFIED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P2 CC: cvasilak, g11n, martinoconnor, mathewboorman, miguelrrc, mmirilovic, rsh2009, sabob, sigalduek, ulfzibis
Version: 6.x   
Target Milestone: 6.x   
Hardware: All   
OS: All   
URL: http://statistics.netbeans.org/exceptions/detail.do?id=144651
Whiteboard: EXCEPTIONS_REPORT, JA_COMMUNITY, 65fixes4-verified
Issue Type: DEFECT Exception Report: 144651
Attachments: stacktrace
stacktrace
stacktrace

Description sflemming 2009-02-04 11:39:46 UTC
Build: NetBeans IDE 6.5 (Build 200811100001)
VM: Java HotSpot(TM) 64-Bit Server VM, 11.2-b01, Java(TM) SE Runtime Environment, 1.6.0_12-b04
OS: Windows Vista, 6.0, amd64

User Comments:
sflemming: Clicked Versioning->Mercurial->Clone other. 
HG 1.1.2 from Tortoise HG package installed.
Same problem with Windows 7 beta built 7000.

GUEST: Clicked on Versioning->Clone other...

GUEST: Trying to clone hg repository. Before installed TortoiseHG, Mercurial Version is 1.1.2

sflemming: Clicked Versioning->Mercurial->Clone other. 
HG 1.1.2 from Tortoise HG package installed.
Same problem with Windows 7 beta built 7000.



Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.mercurial.ui.wizards.ClonePathsPanel.isValid(ClonePathsPanel.java:77)
        at java.awt.Component.invalidateIfValid(Component.java:2740)
        at java.awt.Component.setLocale(Component.java:1810)
        at javax.swing.JComponent.<init>(JComponent.java:595)
        at javax.swing.JPanel.<init>(JPanel.java:65)
        at javax.swing.JPanel.<init>(JPanel.java:92)
Comment 1 sflemming 2009-02-04 11:39:51 UTC
Created attachment 76541 [details]
stacktrace
Comment 2 dustin_mccartney 2009-02-05 08:22:47 UTC
Impact: This bug completely prevents Netbeans users from Cloning Mercurial repos from within the IDE.

Workaround: Use the console.
Comment 3 sflemming 2009-02-05 09:45:12 UTC
Sorry, set the target milestone although I'm not able to fix it. Put it back when noone is able to fix for 6.5.
Console is currently the only way to clone the repository. Opening the clone with NB alows all further hg operation.
Comment 4 Exceptions Reporter 2009-02-07 11:23:44 UTC
This issue has already 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=144651
Comment 5 sabob 2009-02-08 11:57:04 UTC
Build: NetBeans IDE 6.5 (Build 200811100001)
VM: Java HotSpot(TM) 64-Bit Server VM, 11.2-b01, Java(TM) SE Runtime Environment, 1.6.0_12-b04
OS: Linux, 2.6.27-11-generic, amd64

User Comments: 


Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.mercurial.ui.wizards.ClonePathsPanel.isValid(ClonePathsPanel.java:77)
        at java.awt.Component.invalidateIfValid(Component.java:2740)
        at java.awt.Component.setLocale(Component.java:1810)
        at javax.swing.JComponent.<init>(JComponent.java:595)
        at javax.swing.JPanel.<init>(JPanel.java:65)
        at javax.swing.JPanel.<init>(JPanel.java:92)
Comment 6 sabob 2009-02-08 11:57:09 UTC
Created attachment 76708 [details]
stacktrace
Comment 7 Ondrej Vrabec 2009-02-09 12:11:42 UTC
fixed
changeset   : 116680:6bc483f1034d
author      : Ondrej Vrabec <ovrabec@netbeans.org>
date        : Mon Feb 09 13:08:19 CET 2009
summary     : #157898 - NullPointerException at org.netbeans.modules.mercurial.ui.wizards.ClonePathsPanel.isValid
Comment 8 Quality Engineering 2009-02-18 10:29:33 UTC
Integrated into 'main-golden', will be available in build *200902180201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/6bc483f1034d
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: #157898 - NullPointerException at org.netbeans.modules.mercurial.ui.wizards.ClonePathsPanel.isValid
renaming the validation method, the former collided and overrode with Component.isValid()
Comment 9 Ondrej Vrabec 2009-02-23 08:01:54 UTC
*** Issue 158965 has been marked as a duplicate of this issue. ***
Comment 10 Ondrej Vrabec 2009-03-18 09:02:47 UTC
*** Issue 160524 has been marked as a duplicate of this issue. ***
Comment 11 Masaki Katakai 2009-03-18 09:07:19 UTC
Unfortunately this fix has not been integrated into release65_fixes repository.
I got the report from community members in Japan who are using 6.5.1.
Comment 12 Marian Mirilovic 2009-03-18 09:51:20 UTC
You are unfortunately right ... we really missed that issue. Marked as candidate for next patch, but honestly not sure
it will be released soon.
Comment 13 Ondrej Vrabec 2009-03-18 20:13:14 UTC
*** Issue 160583 has been marked as a duplicate of this issue. ***
Comment 14 ulfzibis 2009-03-22 12:41:22 UTC
Build: NetBeans IDE 6.5 (Build 200811100001)
VM: Java HotSpot(TM) Client VM, 11.2-b01, Java(TM) SE Runtime Environment, 1.6.0_12-b04
OS: Windows XP, 5.1, x86

User Comments: 


Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.mercurial.ui.wizards.ClonePathsPanel.isValid(ClonePathsPanel.java:77)
        at java.awt.Component.invalidateIfValid(Component.java:2740)
        at java.awt.Component.setLocale(Component.java:1810)
        at javax.swing.JComponent.<init>(JComponent.java:595)
        at javax.swing.JPanel.<init>(JPanel.java:65)
        at javax.swing.JPanel.<init>(JPanel.java:92)
Comment 15 ulfzibis 2009-03-22 12:41:28 UTC
Created attachment 78593 [details]
stacktrace
Comment 16 martinoconnor 2009-03-23 02:50:27 UTC
Reopening as it occurs in NetBeans IDE 6.5.1 (Build 200903060201)
Comment 17 Ondrej Vrabec 2009-03-23 06:47:33 UTC
fixed, but the fix is not included in 6.5.1
Comment 18 Ondrej Vrabec 2009-03-23 06:47:50 UTC
*** Issue 160834 has been marked as a duplicate of this issue. ***
Comment 19 Jaromir Uhrik 2009-04-02 21:48:31 UTC
I cannot reproduce this issue in trunk builds. Will mark as Verified once the fix is integrated to 6.5 repository.
Comment 20 Ondrej Vrabec 2009-04-07 12:35:27 UTC
back-port to 6.5
fixed as release65_fixes #8225dd0f135d
Comment 21 Jaromir Uhrik 2009-04-09 09:04:42 UTC
Verified in the following build + patch4:

Product Version: NetBeans IDE 6.5.1 (Build 200903060201)
Java: 1.6.0_12; Java HotSpot(TM) Client VM 11.2-b01
System: Windows Vista version 6.0 running on x86; Cp1250; cs_CZ (nb)
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo