Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 155487

Summary: Function breakpoints do not work
Product: cnd Reporter: Alexander Pepin <apepin>
Component: DebuggerAssignee: _ gordonp <gordonp>
Status: VERIFIED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P2 CC: sustaining
Version: 6.x   
Target Milestone: 6.x   
Hardware: All   
OS: All   
Whiteboard: 65fixes2-verified
Issue Type: DEFECT Exception Report:
Attachments: gdb log

Description Alexander Pepin 2008-12-15 17:44:08 UTC
Steps to reproduce:
- create any sample (e.g. Quote)
- set Function BP for 'main'
- set Line BP in line 120
- start debugger
Result: Debugger misses BP in main and stops at line 120
- set Function BP for 'outCustomersList'
- set Line BP in line 123
- do continue
Result: Debugger misses BP in 'outCustomersList'
Comment 1 Alexander Pepin 2008-12-15 17:45:52 UTC
Created attachment 74972 [details]
gdb log
Comment 2 Alexander Pepin 2008-12-15 17:46:32 UTC
it's a regression
Comment 3 Egor Ushakov 2008-12-16 12:20:09 UTC
The problem source is a new breakpoint path check(BreakpointImpl:104):
if (!path.equals(fullname)) 
...

For function breakpoints path is empty and thus always not equals to the real name that we get from the gdb
Comment 4 Alexander Pepin 2008-12-16 15:19:32 UTC
The fix should be included into patch2 as it's a consequence of fixing issue #151761
Comment 5 _ gordonp 2008-12-23 19:49:17 UTC
The fix for IZ #151577 did a path comparison for all breakpoints which was only appropriate
for line breakpoints. I've limited this test to line breakpoints and it should work as
expected.
Comment 6 _ gordonp 2008-12-24 15:36:03 UTC
Forgot to add the changeset when I marked this as fixed yesterday (too much vacation:-)

http://hg.netbeans.org/main?cmd=changeset;node=45fb6c89211f
Comment 7 Alexander Pepin 2008-12-29 19:01:25 UTC
verified in build 200812291401
Comment 8 jinb 2009-01-08 18:39:48 UTC
Hello,
it impossible to apply mentioned changeset(s) to release65_fixes [ref1] branch because a lot of non-this IZ related
changes were made and other changesets pushed into main [ref2] repository between release65_fixes branching time and
mentioned changeset(s) pushing time. Please provide cumulative changeset/ set of changesets applicable to
release65_fixes branch otherwise this fix will be skipped for current NB65 patch.
This problem is common for following IZs: 151761, 151610, 151577, 133134, 155487 
[ref1]: http://hg.netbeans.org/release65_fixes
[ref2]: http://hg.netbeans.org/main
Comment 9 Alexander Pepin 2009-01-14 14:19:14 UTC
verified in NB6.5 with provided jar files
Comment 10 jinb 2009-01-14 17:44:13 UTC
Cumulative backport of fixes of IZ 151481(rebackport), 151577, 151610, 153473, 151640, 151761, 155487, 151631, 133134
provided by developer.
Backported into release65_fixes branch
http://hg.netbeans.org/release65_fixes/rev/84a0c7175a4b
Comment 11 Alexander Pepin 2009-01-19 14:55:44 UTC
verified in patch2
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo