Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 143300

Summary: Mercurial window position isn't persistent
Product: versioncontrol Reporter: Lukas Hasik <lhasik>
Component: MercurialAssignee: issues <issues.netbeans.org>
Status: RESOLVED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P4 CC: banzaimonkey, tboudreau
Version: 6.x   
Target Milestone: 7.1   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: DEFECT Exception Report:
Bug Depends on: 129268    
Bug Blocks:    

Description Lukas Hasik 2008-08-08 14:45:08 UTC
Product Version: NetBeans IDE 6.5 Beta (Build 200808060301)

-follow usecase in issue 143214
-please set up set some level of persistency (TopComponent.PERSISTENCE_ONLY_OPENED or PERSISTENCE_ALWAYS) to the
Mercurial window
Comment 1 Tomas Stupka 2008-09-03 13:40:13 UTC
won't persist until cvscontext is serializable. Otherwise the window would show no data at all. 
Minor usability problem -> p4
Comment 2 Tomas Stupka 2008-09-23 09:33:26 UTC
*** Issue 129276 has been marked as a duplicate of this issue. ***
Comment 3 Tomas Stupka 2008-10-31 10:31:08 UTC
*** Issue 151673 has been marked as a duplicate of this issue. ***
Comment 4 Ondrej Vrabec 2009-12-07 05:46:35 UTC
*** Bug 178163 has been marked as a duplicate of this bug. ***
Comment 5 Ondrej Vrabec 2010-12-28 12:49:12 UTC
*** Bug 193854 has been marked as a duplicate of this bug. ***
Comment 6 Ondrej Vrabec 2011-05-19 10:29:46 UTC
fix: http://hg.netbeans.org/core-main/rev/234088267245
Comment 7 Quality Engineering 2011-05-20 08:55:21 UTC
Integrated into 'main-golden', will be available in build *201105200400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/234088267245
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: Issue #143300 - Mercurial window position isn't persistent
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo