Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 126219

Summary: OutOfMemoryError: Java heap space
Product: platform Reporter: javydreamercsw <javydreamercsw>
Component: AutoupdateAssignee: Jiri Rechtacek <jrechtacek>
Status: RESOLVED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P3 Keywords: PERFORMANCE
Version: 6.x   
Target Milestone: 6.x   
Hardware: All   
OS: All   
URL: http://statistics.netbeans.org/exceptions/detail.do?id=5618
Whiteboard: EXCEPTIONS_REPORT
Issue Type: DEFECT Exception Report: 5618
Bug Depends on:    
Bug Blocks: 126977    
Attachments: stacktrace
stacktrace
stacktrace
stacktrace

Description javydreamercsw 2008-01-29 20:14:37 UTC
Build: NetBeans IDE Dev (Build 200801280931)
VM: Java HotSpot(TM) Client VM, 1.6.0_03-b05
OS: Windows XP, 5.1, x86

User Comments: 
Opening plugin window
Comment 1 javydreamercsw 2008-01-29 20:14:41 UTC
Created attachment 55716 [details]
stacktrace
Comment 2 shabeepk 2008-01-30 06:38:36 UTC
Build: NetBeans IDE 6.0 (Build 200711261600)
VM: Java HotSpot(TM) Client VM, 1.6.0_01-b06
OS: Windows XP, 5.1, x86

User Comments: 
Comment 3 shabeepk 2008-01-30 06:38:39 UTC
Created attachment 55732 [details]
stacktrace
Comment 4 Lukas Hasik 2008-01-30 09:34:26 UTC
what is your machine configuration? How much memory do you have?
Comment 5 javydreamercsw 2008-02-05 12:08:12 UTC
Build: NetBeans IDE Dev (Build 200801280931)
VM: Java HotSpot(TM) Client VM, 1.6.0_03-b05
OS: Windows XP, 5.1, x86

User Comments: 
Opening the Plugin window always raises this error
Comment 6 javydreamercsw 2008-02-05 12:08:21 UTC
Created attachment 56052 [details]
stacktrace
Comment 7 suresh111_mca 2008-02-28 07:42:54 UTC
Build: NetBeans IDE Dev (Build 200801280931)
VM: Java HotSpot(TM) Client VM, 10.0-b19
OS: Windows XP, 5.1, x86

User Comments: 
Comment 8 suresh111_mca 2008-02-28 07:42:58 UTC
Created attachment 57412 [details]
stacktrace
Comment 9 Jiri Rechtacek 2008-02-28 10:09:49 UTC

*** This issue has been marked as a duplicate of 126976 ***
Comment 10 _ theanuradha 2008-10-10 13:19:36 UTC
Product Version: IntegratedDesignerSuite 081007
Java: 1.6.0_10-rc; Java HotSpot(TM) Client VM 11.0-b14
System: Windows XP version 5.1 running on x86; Cp1252; en_US (integrateddesignersuite)
Userdir: D:\projects\office\projects\application_designer\build\testuserdir


[IDE Log]  java.lang.OutOfMemoryError: Java heap space
[IDE Log]          at com.sun.org.apache.xerces.internal.util.XMLStringBuffer.append(XMLStringBuffer.java:205)
[IDE Log]          at 
com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.refresh(XMLDocumentScannerImpl.java:1520)
[IDE Log]          at 
com.sun.org.apache.xerces.internal.impl.XMLEntityScanner.invokeListeners(XMLEntityScanner.java:2070)
[IDE Log]          at com.sun.org.apache.xerces.internal.impl.XMLEntityScanner.skipChar(XMLEntityScanner.java:1415)
[IDE Log]          at 
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(XMLDocumentFragmentSc
annerImpl.java:2784)
[IDE Log]          at 
com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:648)
[IDE Log]          at 
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java
:510)
[IDE Log]          at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:807)
[IDE Log]          at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:737)
[IDE Log]          at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:107)
[IDE Log]          at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1205)
[IDE Log]          at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:522)
[IDE Log]          at javax.xml.parsers.SAXParser.parse(SAXParser.java:395)
[IDE Log]          at 
org.netbeans.modules.autoupdate.updateprovider.AutoupdateCatalogParser.getUpdateItems(AutoupdateCatalogParser.java:148)
[IDE Log]          at 
org.netbeans.modules.autoupdate.updateprovider.AutoupdateCatalogProvider.getUpdateItems(AutoupdateCatalogProvider.java:
110)
[IDE Log]          at 
org.netbeans.modules.autoupdate.services.UpdateUnitFactory.appendUpdateItems(UpdateUnitFactory.java:170)
[IDE Log]          at 
org.netbeans.modules.autoupdate.services.UpdateUnitFactory.getUpdateUnits(UpdateUnitFactory.java:140)
[IDE Log]          at 
org.netbeans.modules.autoupdate.services.UpdateManagerImpl$Cache.<init>(UpdateManagerImpl.java:222)
[IDE Log]          at org.netbeans.modules.autoupdate.services.UpdateManagerImpl.getCache(UpdateManagerImpl.java:196)
[IDE Log]          at 
org.netbeans.modules.autoupdate.services.UpdateManagerImpl.getUpdateUnits(UpdateManagerImpl.java:93)
[IDE Log]          at org.netbeans.api.autoupdate.UpdateManager.getUpdateUnits(UpdateManager.java:100)
[IDE Log]          at 
org.netbeans.modules.autoupdate.ui.actions.AutoupdateCheckScheduler.checkUpdateElements(AutoupdateCheckScheduler.java:1
98)
[IDE Log]          at 
org.netbeans.modules.autoupdate.ui.actions.AutoupdateCheckScheduler$5.run(AutoupdateCheckScheduler.java:177)
[IDE Log]          at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:572)
[IDE Log]  [catch] at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:997)
[IDE Log]  INFO [org.netbeans.modules.uihandler.Installer]: findIdentity: 54c30c9c-baab-49e6-a613-
4e372f40435c_410eca87-c6f5-4233-952e-0934deaa5f99

Comment 11 Jiri Rechtacek 2008-10-10 13:23:28 UTC
It's tracking as issue 148324

*** This issue has been marked as a duplicate of 148324 ***
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo