Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 125962

Summary: Add Never button into User satisfaction survey dialog
Product: ide Reporter: Antonin Nebuzelsky <anebuzelsky>
Component: WelcomeAssignee: Stanislav Aubrecht <saubrecht>
Status: VERIFIED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P2 CC: bambule, gsporar, jfranc, jrojcek, lhasik, mbalin, mmirilovic, pkeegan, sustaining
Version: 6.x   
Target Milestone: 6.x   
Hardware: All   
OS: All   
Whiteboard: release601_fixes_candidate2, release601_fixes_fixed
Issue Type: DEFECT Exception Report:
Attachments: survey dialog screenshot

Description Antonin Nebuzelsky 2008-01-24 22:36:37 UTC
The User Satisfaction Survey dialog asks the user question

"Do you want to participate in NetBeans Users Satisfaction Survey now?"

and it shows these two buttons: "Go to Survey" and "Remind Later".

If the user presses Remind Later three times, the survey dialog never appears again. However, some users are complaining
that they are repeatedly asked to fill in the survey. The users don't know about the rule of three times.

Maybe we should add a new button which would quit the dialog and never ask the user again.

I am not sure what the button should say. "Never" is too short and does not fit the question IMO. "Never Ask Again"
would make more sense to me, but is quite long.

Martin, Jakub, any suggestion?
Comment 1 Martin Balin 2008-01-25 08:00:57 UTC
There are not so much alternatives I think. "Don't ask again" has same number of chars, maybe sounds better.
Comment 2 jrojcek 2008-01-28 16:39:28 UTC
Both suggestions look good to me. "Don't Ask Again" should probably be "Do Not Ask Again", AFAIK we're not using short "Don't" in labels. Ccing Patrick.

Or maybe just:

Go to Survey, Remind Me Later, Cancel

or:

Go to Survey, Remind Me Later, Skip Survey

Comment 3 Martin Balin 2008-01-28 17:06:09 UTC
Skip Survey looks OK for me. Short and explanatory.
Comment 4 Patrick Keegan 2008-01-28 18:44:28 UTC
Skip Survey is OK with me as well
Comment 5 jrojcek 2008-01-29 09:02:44 UTC
While we're at it, I think the wording in the dialog should try to do more in encouraging users to take the survey. Especially now if there's an easy way to skip 
it. I would suggest to change the wording:

---
<strong>Help improve the NetBeans IDE</strong>
Fill in a short 5 question NetBeans User Satisfaction Survey now.
---

The wording needs to be polished some more. Let me know what you think. Patrick, can you please help with it?
Comment 6 Patrick Keegan 2008-01-29 11:05:32 UTC
My take:

<strong>Help us improve the NetBeans IDE</strong>
Fill in a five-question user satisfaction survey now.
Comment 7 Stanislav Aubrecht 2008-01-29 16:37:56 UTC
fixed

changeset# a812eae9c3ad
Comment 8 Martin Balin 2008-02-11 17:33:10 UTC
*** Issue 125306 has been marked as a duplicate of this issue. ***
Comment 9 Lukas Hasik 2008-02-18 13:39:14 UTC
there are some complains from 6.0 users. Maybe we should decide if it's worth to provide it the fix in next patch for
6.0.1 ?
Comment 10 Marian Mirilovic 2008-02-18 14:38:02 UTC
Agreed with Lukas ...
Comment 11 Antonin Nebuzelsky 2008-02-18 14:40:46 UTC
Just note that the fix affects UI and as such should be localized. (6.0.1 is ML!)
Comment 12 Lukas Hasik 2008-02-22 15:38:41 UTC
verified in 2/20 build
Comment 13 Marian Mirilovic 2008-02-24 20:56:47 UTC
*** Issue 124948 has been marked as a duplicate of this issue. ***
Comment 14 pslechta 2008-03-04 15:45:21 UTC
The fix has been ported into the release601_fixes branch.

Checking in Bundle.properties;
/cvs/ide/welcome/src/org/netbeans/modules/welcome/Attic/Bundle.properties,v  <--
  Bundle.properties
new revision: 1.11.4.1.4.1; previous revision: 1.11.4.1
done
Checking in FeedbackSurvey.java;
/cvs/ide/welcome/src/org/netbeans/modules/welcome/Attic/FeedbackSurvey.java,v  <
--  FeedbackSurvey.java
new revision: 1.5.10.1; previous revision: 1.5
done

L10N required:
ide/welcome/src/org/netbeans/modules/welcome/Bundle.properties: key MSG_FeedbackSurvey_Message changed, key
MSG_FeedbackSurvey_Never added.
Comment 15 Petr Chytil 2008-03-13 20:00:47 UTC
A typo in HTML in Bundle.properties (there should be <br> instead of <br/>), JDKs before 1.6.0 doesn't like it - see
attached screenshot (made with 1.5.0).
Comment 16 Petr Chytil 2008-03-13 20:02:17 UTC
Created attachment 58350 [details]
survey dialog screenshot
Comment 17 Stanislav Aubrecht 2008-03-14 11:12:47 UTC
fixed

30430075f369
Comment 18 Lukas Hasik 2008-03-14 11:19:48 UTC
pslechta, sustaining, please backport the fix to the 601 patch2
Comment 19 Lukas Hasik 2008-03-14 12:19:12 UTC
2sustaining- http://hg.netbeans.org/core-main/rev/30430075f369
Comment 20 pslechta 2008-03-14 13:11:27 UTC
Fix backported to release601_fixes branch.

Checking in Bundle.properties;
/cvs/ide/welcome/src/org/netbeans/modules/welcome/Attic/Bundle.properties,v  <-- Bundle.properties
new revision: 1.11.4.1.4.2; previous revision: 1.11.4.1.4.1
done
Comment 21 Lukas Hasik 2008-03-17 13:46:46 UTC
verified with the latest patch2 601
Comment 22 Marian Mirilovic 2008-08-08 10:41:30 UTC
*** Issue 136551 has been marked as a duplicate of this issue. ***
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo