Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 122662

Summary: Swing problem
Product: java Reporter: dagvin <dagvin>
Component: ProjectAssignee: issues <issues.netbeans.org>
Status: RESOLVED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P3 CC: pchytil
Version: 6.x   
Target Milestone: 6.x   
Hardware: PC   
OS: Windows XP   
Whiteboard:
Issue Type: DEFECT Exception Report:

Description dagvin 2007-11-23 20:12:47 UTC
i have problem with insert a JFrame from wizard in my application with netbeans 6 rc2; problem not present in netbeans 6
beta 2. it create a empty file.

the problem is :

java.lang.NullPointerException
	at org.netbeans.modules.java.JavaDataLoader$JavaFileEntry.modifyMap(JavaDataLoader.java:256)
	at org.netbeans.modules.java.JavaDataLoader$JavaFileEntry.createFormat(JavaDataLoader.java:207)
	at org.netbeans.modules.java.IndentFileEntry.createFromTemplate(IndentFileEntry.java:121)
	at org.netbeans.modules.java.JavaDataLoader$JavaFileEntry.createFromTemplate(JavaDataLoader.java:313)
	at org.openide.loaders.MultiDataObject.handleCreateFromTemplate(MultiDataObject.java:707)
	at org.openide.loaders.DataObject$CreateAction.run(DataObject.java:1247)
	at org.openide.loaders.DataObjectPool$1WrapAtomicAction.run(DataObjectPool.java:238)
	at org.openide.filesystems.EventControl.runAtomicAction(EventControl.java:120)
	at org.openide.filesystems.FileSystem.runAtomicAction(FileSystem.java:499)
	at org.openide.loaders.DataObjectPool.runAtomicAction(DataObjectPool.java:250)
	at org.openide.loaders.DataObject.invokeAtomicAction(DataObject.java:861)
	at org.openide.loaders.DataObject.createFromTemplate(DataObject.java:793)
	at org.openide.loaders.DataObject.createFromTemplate(DataObject.java:773)
	at org.netbeans.modules.java.project.NewJavaFileWizardIterator.instantiate(NewJavaFileWizardIterator.java:158)
	at org.netbeans.modules.form.wizard.TemplateWizardIterator.instantiate(TemplateWizardIterator.java:121)
	at org.openide.loaders.TemplateWizard$InstantiatingIteratorBridge.instantiate(TemplateWizard.java:1025)
	at org.openide.loaders.TemplateWizard.handleInstantiate(TemplateWizard.java:595)
	at org.openide.loaders.TemplateWizard.instantiateNewObjects(TemplateWizard.java:416)
	at org.openide.loaders.TemplateWizardIterImpl.instantiate(TemplateWizardIterImpl.java:248)
	at org.openide.loaders.TemplateWizardIteratorWrapper.instantiate(TemplateWizardIteratorWrapper.java:161)
	at org.openide.WizardDescriptor.callInstantiateOpen(WizardDescriptor.java:1387)
	at org.openide.WizardDescriptor.callInstantiate(WizardDescriptor.java:1341)
	at org.openide.WizardDescriptor.access$1600(WizardDescriptor.java:119)
	at org.openide.WizardDescriptor$Listener$2$1.run(WizardDescriptor.java:1908)
	at org.openide.WizardDescriptor$Listener$2.run(WizardDescriptor.java:1957)
	at org.openide.WizardDescriptor.lazyValidate(WizardDescriptor.java:1316)
	at org.openide.WizardDescriptor.access$1200(WizardDescriptor.java:119)
	at org.openide.WizardDescriptor$Listener.actionPerformed(WizardDescriptor.java:1964)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.openide.util.WeakListenerImpl$ProxyListener.invoke(WeakListenerImpl.java:449)
	at $Proxy17.actionPerformed(Unknown Source)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:236)
	at java.awt.Component.processMouseEvent(Component.java:6038)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3265)
	at java.awt.Component.processEvent(Component.java:5803)
	at java.awt.Container.processEvent(Container.java:2058)
	at java.awt.Component.dispatchEventImpl(Component.java:4410)
	at java.awt.Container.dispatchEventImpl(Container.java:2116)
	at java.awt.Component.dispatchEvent(Component.java:4240)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4322)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3986)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3916)
	at java.awt.Container.dispatchEventImpl(Container.java:2102)
	at java.awt.Window.dispatchEventImpl(Window.java:2429)
	at java.awt.Component.dispatchEvent(Component.java:4240)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:177)
	at java.awt.Dialog$1.run(Dialog.java:1039)
	at java.awt.Dialog$3.run(Dialog.java:1091)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.Dialog.show(Dialog.java:1089)
	at org.netbeans.core.windows.services.NbPresenter.superShow(NbPresenter.java:834)
	at org.netbeans.core.windows.services.NbPresenter.doShow(NbPresenter.java:868)
	at org.netbeans.core.windows.services.NbPresenter.run(NbPresenter.java:856)
	at org.netbeans.core.windows.services.NbPresenter.run(NbPresenter.java:104)
	at org.openide.util.Mutex.doEventAccess(Mutex.java:1223)
	at org.openide.util.Mutex.readAccess(Mutex.java:242)
	at org.netbeans.core.windows.services.NbPresenter.show(NbPresenter.java:841)
	at java.awt.Component.show(Component.java:1419)
	at java.awt.Component.setVisible(Component.java:1372)
	at java.awt.Window.setVisible(Window.java:801)
	at java.awt.Dialog.setVisible(Dialog.java:979)
	at org.openide.loaders.TemplateWizard.instantiateImpl(TemplateWizard.java:502)
	at org.openide.loaders.TemplateWizard.instantiate(TemplateWizard.java:381)
	at org.netbeans.modules.project.ui.actions.NewFile.doPerform(NewFile.java:147)
	at org.netbeans.modules.project.ui.actions.NewFile.access$200(NewFile.java:80)
	at org.netbeans.modules.project.ui.actions.NewFile$PopupListener.actionPerformed(NewFile.java:340)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:357)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1216)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1257)
	at java.awt.Component.processMouseEvent(Component.java:6038)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3265)
	at java.awt.Component.processEvent(Component.java:5803)
	at java.awt.Container.processEvent(Container.java:2058)
	at java.awt.Component.dispatchEventImpl(Component.java:4410)
	at java.awt.Container.dispatchEventImpl(Container.java:2116)
	at java.awt.Component.dispatchEvent(Component.java:4240)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4322)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3986)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3916)
	at java.awt.Container.dispatchEventImpl(Container.java:2102)
	at java.awt.Window.dispatchEventImpl(Window.java:2429)
	at java.awt.Component.dispatchEvent(Component.java:4240)
[catch] at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:173)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:168)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:160)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:121)
Comment 1 Petr Chytil 2007-11-26 12:49:00 UTC
reassigning to java for evaluation.
Comment 2 Jan Lahoda 2007-12-06 09:03:23 UTC
Has been already solved as issue #123006 - see that issue for more info. Thanks for the report anyway.

pchytil, please select "Reassign issue to owner of selected subcomponent" when reassigning bugs, so it gets assigned to
a correct person.

*** This issue has been marked as a duplicate of 123006 ***
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo