Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 118239

Summary: Allow reverting the overriding module to base version
Product: platform Reporter: kirillkh <kirillkh>
Component: Plugin ManagerAssignee: Jiri Rechtacek <jrechtacek>
Status: RESOLVED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P3    
Version: 6.x   
Target Milestone: TBD   
Hardware: PC   
OS: All   
Whiteboard:
Issue Type: ENHANCEMENT Exception Report:

Description kirillkh 2007-10-09 14:58:07 UTC
Product Version: NetBeans IDE Dev (Build 20071009102105)
Java: 1.6.0_01; Java HotSpot(TM) Client VM 1.6.0_01-b06
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)
-----------------------------------------------------------------

Sometimes I want to update a module found in UC updates to the local user dir even though a previous version is already
installed in the base NB dir. This can happen, when the version of the module in the base dir is broken, and I suspect
that the updated version might fix the problem. After that, there are 2 possible paths I might want to take:
1. if the update doesn't fix the problem, I'll usually want to revert to the base version -- but I can't do it without
uninstalling the module first, which is disastrous, when many other modules depend on this one (they all get disabled,
and after the restart you have to hunt them one-by-one and enable specially).
2. if the update fixes the problem, I'll want to keep it until I make a new install of the NB, at which point I'll want
to revert to the new base version -- which causes the same troubles as p.1

What I'd like to have is "Revert" action that would not only remove the module from the user dir, but do it without
disabling the plugins (since after NB is restarted, the plugin in the base directory will be enabled). The only case,
when I want a dependent plugin to be disabled, is when it depends on the newer version of the reverted plugin and can't
work with the one installed in the base directory.

In addition to this, I'd also like to have visual indications of the following:
1. where the module resides - in the user dir or in the base dir (also see issue #118234)
2. whether the given module "shadows" a module in the base dir (for such modules, the Revert action should be enabled)
Comment 1 Jiri Rechtacek 2008-10-16 18:01:24 UTC

*** This issue has been marked as a duplicate of 49619 ***
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo