Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 114391

Summary: NullPointerException after creating new ws
Product: javaee Reporter: Lukas Jungmann <jungi>
Component: CodeAssignee: martin_adamek <martin_adamek>
Status: VERIFIED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P3 CC: jhorvath
Version: 6.x   
Target Milestone: 6.x   
Hardware: All   
OS: All   
URL: http://statistics.netbeans.org/exceptions/detail.do?id=2637
Whiteboard: EXCEPTIONS_REPORT
Issue Type: DEFECT Exception Report: 2637
Attachments: stacktrace

Description Lukas Jungmann 2007-08-31 15:49:51 UTC
Build: NetBeans IDE Dev (Build 200708310258)
VM: Java HotSpot(TM) Client VM, 1.6.0-b105
OS: Linux, 2.6.20-16-generic, i386

User Comments: 

-create new EJB module (Java EE 5)
-create new local session bean there
-add some dummy business method there (ie. myBm(String): String)
-create new web service which delegates to local session bean in the same EJB module

=> NPE
Comment 1 Lukas Jungmann 2007-08-31 15:49:55 UTC
Created attachment 47896 [details]
stacktrace
Comment 2 nouar38 2007-09-04 14:39:58 UTC
Hit this issue on netbeans-6.0-200709021200/solaris sparc and Build 200709030000/windows-xp jdk1.6u1
with a similar ejb  module in which I've created:
1 stateless session bean, 
1 stateful session bean,
1 entity from db. 

But when  added a web service to it (empty web service 
choice) 
==>> NPE as the one shown, the web service has been created and can add an op to it.
==>> Enterprise Beans node in Projects has no more the two session beans added first.
Comment 4 Lukas Jungmann 2007-09-18 11:09:28 UTC
*** Issue 115790 has been marked as a duplicate of this issue. ***
Comment 5 Lukas Jungmann 2007-10-22 15:27:14 UTC
v.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo