Bug 112344

Summary: DnD in schema view throws exception
Product: xml Reporter: tonybeckham <tonybeckham>
Component: Schema ToolsAssignee: Sonali Kochar <sonali>
Status: VERIFIED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P4 CC: samaresh, sonali
Version: 6.xKeywords: JDK_SPECIFIC, RELNOTE
Target Milestone: 6.x   
Hardware: All   
OS: Linux   
Whiteboard:
Issue Type: DEFECT Exception Report:
Attachments: Log file from Solaris x86

Description tonybeckham 2007-08-08 19:10:42 UTC
Product Version: NetBeans IDE Dev (Build 200708080000) 
Java: 1.6.0; Java HotSpot(TM) Client VM 1.6.0-b105 
System: Linux version 2.6.20-16-generic running on i386; UTF-8; en_US (nb)

Problem:
Drag and Drop in schema view throws exception

Steps:
-Create a new schema
-In schema view, tree view, add a new element from context menu, all accept defaults
-add another new element from context menu, accept all defaults
-for the first element (newElement) create a new element from the context menu, call it newElementA
-for the second element (newElement1) create a new element from the context menu, call it newElementB
-Drag and Drop newElementB from newElement1 to newElement

Exception:

java.lang.NullPointerException
	at sun.awt.X11.XSelection.checkChange(XSelection.java:749)
	at sun.awt.X11.XSelection.access$200(XSelection.java:30)
	at sun.awt.X11.XSelection$SelectionEventHandler.dispatchEvent(XSelection.java:758)
	at sun.awt.X11.XToolkit.dispatchEvent(XToolkit.java:482)
	at sun.awt.X11.XToolkit.run(XToolkit.java:626)
	at sun.awt.X11.XToolkit.run(XToolkit.java:560)
[catch] at java.lang.Thread.run(Thread.java:619)
Comment 1 tonybeckham 2007-08-09 15:58:41 UTC
Product Version: NetBeans IDE Dev (Build 200708080000) 
Java: 1.5.0_11; Java HotSpot(TM) Client VM 1.5.0_11-b03 
System: Linux version 2.6.20-16-generic running on i386; UTF-8; en_US (nb)

Repeating the steps with Java 1.5 no exception is thrown in the IDE but the console output shows this NPE:


Exception on Toolkit thread: java.lang.NullPointerException
java.lang.NullPointerException
        at sun.awt.X11.XSelection.checkChange(XSelection.java:701)
        at sun.awt.X11.XSelection.access$200(XSelection.java:28)
        at sun.awt.X11.XSelection$SelectionEventHandler.dispatchEvent(XSelection.java:710)
        at sun.awt.X11.XToolkit.dispatchEvent(XToolkit.java:408)
        at sun.awt.X11.XToolkit.run(XToolkit.java:493)
        at sun.awt.X11.XToolkit.run(XToolkit.java:438)
        at java.lang.Thread.run(Thread.java:595)
Comment 2 tonybeckham 2007-08-09 16:16:41 UTC
Product Version: NetBeans IDE Dev (Build 200708081200) 
Java: 1.5.0_07; Java HotSpot(TM) Client VM 1.5.0_07-87 
System: Mac OS X version 10.4.10 running on i386; MacRoman; en_US (nb)

Not reproducible on MacOS.
Comment 3 tonybeckham 2007-08-09 18:02:40 UTC
Not reproducible on Win XP.
Comment 4 tonybeckham 2007-08-14 19:51:23 UTC
This issue only occurs on linux so I am marking it as such.
Comment 5 tonybeckham 2007-08-14 19:53:40 UTC
Also, I wanted to downgrade this to P3 after discussions with sonali.
Comment 6 tonybeckham 2007-09-24 20:17:24 UTC
Seen on Solaris x86 also.  Since this is a functionality set forth in the spec we need to fix it so I am raising back to
P2.  We can discuss this if you want.
Comment 7 Samaresh Panda 2007-09-24 20:45:35 UTC
I suggest we file a bugs on JDK(x86, Linux), because we really can't do much here from our side.
Comment 8 tonybeckham 2007-09-25 22:56:24 UTC
Created attachment 49518 [details]
Log file from Solaris x86
Comment 9 tonybeckham 2007-09-25 23:04:17 UTC
Product Version: NetBeans IDE Dev (Build 200709250000) 
Java: 1.5.0_11; Java HotSpot(TM) Client VM 1.5.0_11-b03 
System: SunOS version 5.11 running on x86; ISO646-US; en (nb)

Solaris x86 Java 1.5 does not have any exceptions, not even in the log file.
Comment 10 tonybeckham 2007-09-26 18:26:11 UTC
I filed bug against JDK for this, it is bug id: 1075095
Comment 11 tonybeckham 2007-09-27 21:18:37 UTC
The bug against the JDK was marked as a duplicate of this issue:
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6511815

It says it has been fixed.  I'll update my JDK and see if I still see the problem.  I think there should be a note on
this in the FAQ for 6.0 since Linux and Solaris users will see the exception unless they have JDK6u2.
Comment 12 tonybeckham 2007-09-28 16:38:42 UTC
I verified that using JDK1.6.0_02 fixes this issue.  Since it wasn't even problem in the first place can we close this
bug?  Like I said previously, I do think there should be a RN or FAQ on this since not everyone will be using the
latests JDK.
Comment 13 Samaresh Panda 2007-09-28 16:59:32 UTC
I agree, please follow the RN process.
Comment 14 tonybeckham 2007-10-02 20:56:43 UTC
Release note should be:

Description: Drag and Drop for XML schema in schema view's tree view may throw exception.

Workaround: Use JDK 1.6.0_02 or later
Comment 15 Max Sauer 2007-10-11 10:39:34 UTC
This is a duplicate of 82142..

*** This issue has been marked as a duplicate of 82142 ***
Comment 16 tonybeckham 2007-10-15 23:48:31 UTC
Fixed with updating JDK to 1.6.0_03 as the RN states.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo