Bug 10399

Summary: Changes of breakpoint's properties are not propagated.
Product: debugger Reporter: Jan Stola <jstola>
Component: CodeAssignee: Marian Petras <mpetras>
Status: CLOSED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P1    
Version: 3.x   
Target Milestone: 3.x   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: DEFECT Exception Report:

Description Jan Stola 2001-03-16 11:58:39 UTC
Netbeans release 3.2 (build 6)
==============================

When you change some property of breakpoint during debugging
this change will not be propagated into the debugged application.

Steps to reproduce:
-------------------
1. Create two breakpoints.
2. When the debugged application is stopped on the first breakpoint,
   change some property (like Line number for line breakpoints).
3. Continue debugging.
4. The debugger will stop on the previous location of the second breakpoint.
5. Finish debugging.
6. Debug your application again. New location of the second breakpoint
   will be used.

So it seems that the new value is set only in the IDE, but not in the debuggee.
Comment 1 Marian Petras 2001-03-27 20:43:15 UTC
Fixed. (main trunk, release32)
Comment 2 Jan Stola 2001-03-30 14:48:22 UTC
I am still able to reproduce this bug in Netbeans release 3.2 (build 16):
try to change method name of method breakpoint during debugging.
Comment 3 Marian Petras 2001-04-03 15:24:29 UTC
Fixed. (main trunk, release32)

The previous fix (2001-03-27) was only for LineBreakpoint.
The current fix corrects also MethodBreakpoint, ExceptionBreakpoint and
VariableBreakpoint.
Comment 4 Jan Stola 2001-04-05 17:12:14 UTC
Verified in Netbeans release 3.2 build 21.
Comment 5 Jan Chalupa 2001-05-05 21:30:19 UTC
Target milestone -> 3.2
Comment 6 Quality Engineering 2003-06-30 17:29:04 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo