Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 103582

Summary: Go To submenu in editor context menu in editor has wrong order of items
Product: java Reporter: Ondrej Langr <olangr>
Component: EditorAssignee: Petr Hrebejk <phrebejk>
Status: RESOLVED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P2 CC: jrojcek
Version: 6.x   
Target Milestone: 6.x   
Hardware: PC   
OS: Windows XP   
Whiteboard:
Issue Type: DEFECT Exception Report:
Bug Depends on: 103187    
Bug Blocks:    

Description Ondrej Langr 2007-05-09 17:31:34 UTC
The order of items currently is: 
   Test
   Super Implementation
   Type
   Source
   Line
   Declaration

The order should be: 
   Source
   Declaration
   Super Implementation
   Test
   Type
   Line
Comment 1 jrojcek 2007-05-10 14:36:23 UTC
Note that I want to do a UI spec for all editor contextual menus for 6.0. What Ondra proposed looks 
good to me. The only thing I would suggest is to remove Type from the Go To submenu. Mostly 
because only those actions that are contextual to selected *code* or selected *file* should be present in 
editor's contextual menu. Type is clearly unrelated to selected code.

So the menu would look like this:

Source
Declaration
Super Implementation
Test
Line...
Comment 2 Jan Lahoda 2007-06-13 09:46:23 UTC
Should be much simpler to do once issue #103187 is done. Maybe post M10, if acceptable.
Comment 3 Ondrej Langr 2007-06-13 10:25:30 UTC
Please note that the proposal above is no more relevant. The UI specification of editor contextual menus (done by Jano
Rojcek) is here: http://wiki.netbeans.org/wiki/view/EditorContextualMenus .
Comment 4 Jan Lahoda 2007-06-13 10:34:06 UTC
Ok, thanks for information.
Comment 5 Petr Hrebejk 2007-07-10 16:55:33 UTC
Actions renamed to Go to ... The rest dupe of 107998

Checking in editor/libsrc/org/netbeans/editor/Bundle.properties;
/cvs/editor/libsrc/org/netbeans/editor/Bundle.properties,v  <--  Bundle.properties
new revision: 1.75; previous revision: 1.74
done
Checking in java/editor/src/org/netbeans/modules/editor/java/Bundle.properties;
/cvs/java/editor/src/org/netbeans/modules/editor/java/Bundle.properties,v  <--  Bundle.properties
new revision: 1.24; previous revision: 1.23
done

*** This issue has been marked as a duplicate of 107998 ***
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo