Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 103371

Summary: Indexing blocks or takes up to much disk and CPU time and isn't very background oriented to allow other features to continue to work
Product: java Reporter: _ wadechandler <wadechandler>
Component: SourceAssignee: Tomas Zezula <tzezula>
Status: RESOLVED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P3    
Version: 6.x   
Target Milestone: 6.x   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: DEFECT Exception Report:

Description _ wadechandler 2007-05-05 16:37:01 UTC
Using NB 6.0 M9 I notice that Indexing is at times either blocking project
opening or it is consuming so much disk and CPU time (not sleeping the thread a
little in between files) that it blocks by accident.  This provides a bad user
experience, and I'm more worried about new users.  Obviously this doesn't happen
all the time, but when it happens over large packages such as the JDK or a huge
project this takes a long amount of time.

Steps when I noticed this (not always reproduceable):
1) Have a "full" installation of 6.0 M9 or later or daily build.
2) If a user directory is already available remove it.
3) Open a newly installed IDE.
4) Open a project.
5) It takes a while to get it to open (notice Indexing will appear in the status
window).

I have noticed this at other times before.  This time I could not get a good log
because I was trying to reproduce and deleted my user directory.  Today I have
not been able to reproduce, but I'll keep trying from time to time.  It took a
very long time to get the projects to open after I had first installed the IDE
and then opened some previous projects which were created with a daily build. 
I'm not sure if there was some kind of a JVM caching that took place or what
accounts for this, but I'll keep looking.
Comment 1 Tomas Zezula 2007-06-22 07:43:18 UTC
The IDE needs to do deeper analyzes of the source code like Idea otherwise the IDE will not be able to provide smart
features like code completion providing only subclasses of Throwable behind throws. There are several things we want to
do to improve the out of box experience (prescanning of jdk & IDE bundled libraries, better interruption of source
scanninig)
Comment 2 Tomas Zezula 2007-07-09 16:28:49 UTC
The scan of jar files was improved (there was problem on Windows - strange behavior of caches on FS).
rt.jar on Windows 80s -> now 12s

Checking in org/netbeans/modules/java/source/parsing/FileObjects.java;
/cvs/java/source/src/org/netbeans/modules/java/source/parsing/FileObjects.java,v  <--  FileObjects.java
new revision: 1.13; previous revision: 1.12
done
Checking in org/netbeans/modules/java/source/parsing/SourceFileObject.java;
/cvs/java/source/src/org/netbeans/modules/java/source/parsing/SourceFileObject.java,v  <--  SourceFileObject.java
new revision: 1.15; previous revision: 1.14
done
Checking in org/netbeans/modules/java/source/usages/BinaryAnalyser.java;
/cvs/java/source/src/org/netbeans/modules/java/source/usages/BinaryAnalyser.java,v  <--  BinaryAnalyser.java
new revision: 1.13; previous revision: 1.12
done
Comment 3 Jiri Prox 2008-04-11 00:53:05 UTC
moving opened issues from TM <= 6.1 to TM=Dev
Comment 4 Jiri Prox 2008-04-21 13:30:20 UTC
Is this issue still valid? The startup time and the opening project was improved in 6.1
Comment 5 johnmuir 2008-05-27 06:39:33 UTC
This issue is very much current in 6.1. Starting the IDE, when you have a large project open, takes 10-15 minutes and
blocks any chance of using the IDE. 

This is a real stopper for using Netbeans with enterprise-size projects. Please do something, anything! 

Move the indexing and scanning, if they are really necessary, to a low priority background thread. 

Or store the information for the next startup, so it need not be repeated on every startup.
Comment 6 johnmuir 2008-05-27 06:40:30 UTC
This issue is very much current in 6.1. Starting the IDE, when you have a large project open, takes 10-15 minutes and
blocks any chance of using the IDE. 

This is a real stopper for using Netbeans with enterprise-size projects. Please do something, anything! 

Move the indexing and scanning, if they are really necessary, to a low priority background thread. 

Or store the information for the next startup, so it need not be repeated on every startup.
Comment 7 Jan Becicka 2008-08-05 13:40:44 UTC

*** This issue has been marked as a duplicate of 133943 ***
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo