Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 103214

Summary: Actions available in popup menu after module uninstallation
Product: versioncontrol Reporter: novakm <novakm>
Component: CodeAssignee: issues <issues.netbeans.org>
Status: VERIFIED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P3    
Version: 6.x   
Target Milestone: 6.x   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: DEFECT Exception Report:
Attachments: Exception Stacktrace

Description novakm 2007-05-03 10:21:11 UTC
I uninstalled the Mercurial module, but the popup menu invoked on a versioned
project in Projects view was still available. After choosing any action,
follwing exception appeared:

java.io.IOException: Top component hgversioning could not be loaded, either owni
ng module was disabled, has incompatible version or top components settings file
 format is broken.
        at org.netbeans.core.windows.persistence.PersistenceManager.getTopCompon
entPersistentForID(PersistenceManager.java:496)
        at org.netbeans.core.windows.persistence.PersistenceManager.getTopCompon
entForID(PersistenceManager.java:587)
...

NetBeans IDE 6.0 Preview (M9, build 070502)
1.5.0_11; Java HotSpot(TM) Client VM 1.5.0_11-b03
Linux version 2.6.9-1.667 running on i386
en_US (nb); UTF-8
Comment 1 novakm 2007-05-03 10:22:39 UTC
Created attachment 42086 [details]
Exception Stacktrace
Comment 2 John Rice 2007-05-03 11:32:51 UTC
Will target fix for rev 1.1

We are not doing anything special on uninstall. Is there something we need to
set to make the Versioning framework refresh it's menus?
Comment 3 novakm 2007-05-03 11:54:01 UTC
Well I just found out, that other modules (Subversion for instance) behave the
same, so it is not probably caused by your module. It must have changed with the
new module manager as it worked before I think. I'll try to find out more and
update here as soon as I'll know anything.
Comment 4 Maros Sandor 2007-05-03 12:12:05 UTC
I guess this is not a problem of mercurial.
Comment 5 Maros Sandor 2007-05-11 13:03:11 UTC
I think that I fixed this lately, please verify in latest builds.
Comment 6 novakm 2007-05-29 12:44:15 UTC
Verified.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo