Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 243024

Summary: Use FindBugs compatible with JDK 1.8
Product: java Reporter: Jesse Glick <jglick>
Component: FindBugsAssignee: Petr Cyhelsky <cyhelsky>
Status: RESOLVED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P2 CC: alied, anebuzelsky, axlm, dengr, dstrupl, elennaro, galambos, jglick, jkovalsky, MackSix, markiewb, peterhull90, ralphbenjamin, stefan79, ttampe, witbrock, zdenek.rod
Version: 8.0Keywords: JDK_8
Target Milestone: 8.0.1   
Hardware: All   
OS: All   
Whiteboard: EXCEPTIONS_REPORT
Issue Type: DEFECT Exception Report: 208487
Attachments: stacktrace
stacktrace
stacktrace
stacktrace
stacktrace
stacktrace
stacktrace
stacktrace
stacktrace

Description Jesse Glick 2014-03-18 20:21:17 UTC
This bug was originally marked as duplicate of bug 235089, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 20140317-eacabc97e7bc)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.0-b70, Java(TM) SE Runtime Environment, 1.8.0-b132
OS: Linux

User Comments:
zdenek.rod: I open java file.

jglick: Just made a new project.

GUEST: Classpath scanning




Stacktrace: 
java.lang.ArrayIndexOutOfBoundsException: 2560
   at org.objectweb.asm.ClassReader.readClass(ClassReader.java:0)
   at org.objectweb.asm.ClassReader.accept(ClassReader.java:0)
   at edu.umd.cs.findbugs.asm.FBClassReader.accept(FBClassReader.java:44)
   at org.objectweb.asm.ClassReader.accept(ClassReader.java:0)
   at edu.umd.cs.findbugs.classfile.engine.ClassParserUsingASM.parse(ClassParserUsingASM.java:106)
   at edu.umd.cs.findbugs.classfile.engine.ClassParserUsingASM.parse(ClassParserUsingASM.java:492)
Comment 1 Jesse Glick 2014-03-18 20:21:19 UTC
Created attachment 146126 [details]
stacktrace
Comment 2 Jesse Glick 2014-03-18 20:38:52 UTC
Created attachment 146127 [details]
stacktrace

Looking at a Java class (-source 6).
Comment 3 Jesse Glick 2014-03-18 20:40:24 UTC
I am running a custom build of the FindBugs plugin, but I took care to include the purported fix of #235089 (by updating to current sources before applying my unrelated patch) and this still seems to happen. Also I am not using Java 8 sources at the moment.
Comment 4 alied 2014-03-19 04:12:01 UTC
Created attachment 146130 [details]
stacktrace

editing a javascript source file
Comment 5 Exceptions Reporter 2014-03-19 04:12:07 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=208487
Comment 6 peterhull90 2014-03-19 13:24:11 UTC
Created attachment 146144 [details]
stacktrace

Using findbugs
Comment 7 Exceptions Reporter 2014-03-20 21:45:31 UTC
Created attachment 146195 [details]
stacktrace

Source -> Inspect -> Findbugs -> BANG!
Comment 8 Jesse Glick 2014-03-21 16:10:31 UTC
Of course this only happens when running under JDK 8.
Comment 9 alied 2014-03-21 16:15:16 UTC
(In reply to Jesse Glick from comment #8)
> Of course this only happens when running under JDK 8.

Exactly!
Although not using Java 8 sources, I'm using Java 8 to run the IDE and as default Java platform.
Comment 10 alied 2014-03-24 13:27:41 UTC
Created attachment 146272 [details]
stacktrace

just installed latest findbug plugin.
Comment 11 Exceptions Reporter 2014-03-24 13:27:47 UTC
This bug already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=208487
Comment 12 stefan79 2014-04-07 05:25:38 UTC
Created attachment 146594 [details]
stacktrace

Exception occured after moving a junit-class to an other folder.
Comment 13 Ralph Ruijs 2014-04-08 11:01:41 UTC
Created attachment 146624 [details]
stacktrace

Tried to run FB on a simple java class
Comment 14 Ralph Ruijs 2014-04-08 11:12:10 UTC
Findbugs is not working when NetBeans is running on Java 8, increasing priority.
Comment 15 alied 2014-04-29 17:21:00 UTC
Created attachment 147011 [details]
stacktrace

executing a Findbugs inspection in a Java project.
The project is a Maven Jira plugin (<packaging>atlassian-plugin</packaging>)
Comment 16 witbrock 2014-05-14 15:45:18 UTC
Seems to happen when a new class is created, as well as when a file is opened by clicking on an exception link.
Comment 17 Petr Cyhelsky 2014-07-11 01:35:53 UTC
fixed in jet-main: 31957c9af780
Comment 18 Petr Cyhelsky 2014-07-11 02:11:01 UTC
*** Bug 239633 has been marked as a duplicate of this bug. ***
Comment 19 Quality Engineering 2014-07-17 02:17:55 UTC
Integrated into 'main-silver', will be available in build *201407170001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/31957c9af780
User: Petr Cyhelsky <cyhelsky@netbeans.org>
Log: #243024 - Update findbugs library to version 3.0.0
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo