Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 154624

Summary: Remove override of java.awt.Component.isValid()
Product: ide Reporter: _ tboudreau <tboudreau>
Component: CodeAssignee: issues <issues.netbeans.org>
Status: RESOLVED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P1 CC: anebuzelsky, mmirilovic, mslama, pjiricka, psuchomel, vkraemer
Version: 6.xKeywords: UMBRELLA
Target Milestone: 6.x   
Hardware: All   
OS: All   
Whiteboard: issue_reviewed
Issue Type: DEFECT Exception Report:
Bug Depends on: 150223, 154408, 154626, 157326, 157827, 157965, 158192, 158449, 158456, 158464, 158465, 158504, 158505, 158608, 158677, 158678, 167352    
Bug Blocks: 157839, 158079, 158100, 158161, 158307    
Attachments: grep for suspect classes

Description _ tboudreau 2008-12-04 15:39:21 UTC
See relevant discussion here:
http://www.nabble.com/Need-%22process%27-help...-td20797793.html
Comment 1 _ tboudreau 2008-12-04 15:56:16 UTC
Logging added in e92edc1d7133
Comment 2 Vince Kraemer 2008-12-04 16:06:17 UTC
Created attachment 74543 [details]
grep for suspect classes
Comment 3 Vince Kraemer 2008-12-04 16:14:21 UTC
the suspect list shows that this is a pervasive coding error, not confined to the server integration modules... so ide
is the correct component.
Comment 4 mslama 2009-02-13 08:57:15 UTC
In most cases overriding of java.awt.Component.isValid() is incorrect in NB code base.
Possible incorrect usages:
1.Simple override from uknown reason probably left from following cases. Not used anywhere but in java.awt.Component.
Delete this overrides.
2.Class extends java.awt.Component and implements WizardDescriptor.Panel. Split it.
3.Class extends java.awt.Component and implements org.netbeans.spi.debugger.ui.Controller. It was fixed in issue #158192
and changeset http://hg.netbeans.org/main/rev/39b9fb269554
Comment 5 Marian Mirilovic 2009-02-17 11:45:54 UTC
*** Issue 158623 has been marked as a duplicate of this issue. ***
Comment 6 Marian Mirilovic 2009-03-03 10:08:38 UTC
all issues have already been addressed in current trunk (6.7) and are prepared for NetBeans 6.5.1 release, for more
details see http://wiki.netbeans.org/NetBeans651
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo