Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 123675

Summary: some required modules are missing from the build
Product: platform Reporter: jamesdoulton <jamesdoulton>
Component: Plugin ManagerAssignee: issues <issues.netbeans.org>
Status: RESOLVED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P2    
Version: 6.x   
Target Milestone: TBD   
Hardware: PC   
OS: Windows Vista   
Whiteboard: EXT-USER
Issue Type: DEFECT Exception Report:

Description jamesdoulton 2007-12-08 09:51:57 UTC
After installing netbeans 6.0 (Build 200711261600) on a new machine the UML modules fail to initialise when launching 
the IDE. If I attempt to activate UML from the Tools, Plugins panel then I get the following error message:

Activation failed: Not all requested modules can be enabled: [StandardModule:org.netbeans.modules.uml.kit jarFile: 
C:\Program Files\NetBeans 6.0\uml4\modules\org-netbeans-modules-uml-kit.jar]

Required modules for plugin UML to complete activation: 
module org.netbeans.modules.uml/1 > 1.1 
module org.netbeans.modules.uml/1 > 1.2 
module org.netbeans.modules.uml/1 > 1.2.0

I have tried the the minimum version and then adding in the UML plugin and I tried downloading the complete Windows 
version and also the version that came bundled with JDK 6 Update 3 and they are all the same.
Comment 1 Peter Lam 2007-12-10 23:25:05 UTC
Is your User Account Control on? If so, this problem might be related to the one in issue 122186. 
Comment 2 jamesdoulton 2007-12-11 09:42:01 UTC
Initially UAC was on. I read the related issue 122186 and it appears identical to my problem.

However, I uninstalled NB6 and then turned UAC off and repeated the install as administrator. I set the protections on 
the netbeans folder, in program files, to allow give all users full control and applied it to all sub-folders and 
files. I changed the NB desktop shortcut to "Run as administrator" and ran the ide, still with uac turned off. I found 
that UML was still shown as deactivated, in the plugins manager, and I still got the same error when I tried to 
activate it. I tried this procedure twice, without any effect. I installed the full windows version but with SOA and 
the two server options removed.
Comment 3 Peter Lam 2007-12-11 17:01:28 UTC
after you turn off UAC, you needed to uninstall the previously installed UML plugin first, because it was not installed
properly. Then, reinstall UML again for it to work. You might also want to restart NB in a fresh ide userdir before
doing the reinstall again. 
Did the install work for you when you installed with the full windows version as you indicated?
Comment 4 jamesdoulton 2007-12-11 23:58:38 UTC
It was the full Windows version that I was trying, sorry if I misled you. With uac turned off, I have tried 
uninstalling the UML plugin and then installing it again with no luck. I have tried uninstalling the whole Netbeans 
and reinstalling. I have tried installing a minimal version of NB6 and then adding the plugin and I have tried 
installing the full version. In each case I have run the installer as administrator and I ran the ide as administrator 
and I had uac turned off throughout. I also set the permissions on the netbeans directory and all its children and 
files. In all cases it hasn't worked for me. I have tried using a different directory in the install each time. 

I notice that each time I re-install, the IDE still knows about my project.
Comment 5 Peter Lam 2007-12-12 00:17:48 UTC
Thanks for the clarification.

> I notice that each time I re-install, the IDE still knows about my project.
Re-installing NetBeans doesn't clean out the following ide userdir so it still knows your project. You need to start ide
in a fresh ide userdir. If you don't have anything important there, you can delete it or rename it before or after you
reinstall NetBeans and before you re-start NetBeans. 

   {user-home-dir}\.netbeans\6.0 

If you're re-installing the full windows version including the UML Plugin, you might want to delete the
{user-home-dir}\.nbi  directory before you re-install.
Comment 6 donpellegrino 2007-12-12 19:57:20 UTC
I am able to reproduce this problem.  I am also unable to activate the UML module using NetBeans 6.0 on Vista.
Comment 7 jamesdoulton 2007-12-12 21:43:40 UTC
Okay, so now I understand - you had meant to remove/rename the user directory right at the top-level of my user 
account in Windows, I hadn't realised that netbeans created it. So I have done that and now it all works! After the 
install and running for the first time, I have now turned uac back on and it all works fine. Thank you for your 
patient help.
Comment 8 donpellegrino 2007-12-12 21:49:27 UTC
I don't think FIXED is the appropriate resolution for this issue.  The process given in the description is really a 
work-around.  The capability to install the UML plugin as designed during normal operation of NetBeans 6.0 on Vista 
should be directly addressed.  Forcing users to follow this work-around will frustrate many people and limit the use 
of the UML plugin.
Comment 9 Peter Lam 2007-12-12 22:04:47 UTC
jamesdoulton, good to hear that the workaround is working for you. Thanks for the update.
donpellegrino, you're right. This is not considered a fix. It's just a workaround. I left it open just to communicate
with  jamesdoulton to make sure the workaround is good. Now that the workaround works and I'm going to mark this a
duplicate of issue 122186. The responsible engr is now looking into evaluating issue 122186 on Vista.
Comment 10 Peter Lam 2007-12-12 22:05:14 UTC

*** This issue has been marked as a duplicate of 122186 ***
Comment 11 Peter Lam 2007-12-12 22:07:06 UTC
because this issue is not specific to just the UML Plugin, I'm going to reclassify it to the autoupdate component as well.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo